BlackBerry Client for OCS 2007 R2 Update

April 4, 2011 Update:  BES 5.0 SP3 has been released which adds support for Microsoft OCS 2007 R2. SeeBlackberry Support for OCS 2007 R2 and Lync is Now Available for more information.

A quick post regarding the availability of a native BlackBerry client that works with OCS 2007 R2.

A representative from RIM recently confirmed that a BlackBerry client that works with OCS 2007 R2 is in the works. They are building this client to work with the next release of OCS (see OCS in 2010 – The UC 14 Wave) but it will be backward compatible and work with OCS 2007 R2 – RIM understandably doesn’t want to build a version now solely for OCS 2007 R2 and then have to build another to support the next release of OCS.

No specific release date is available, although ‘this summer’ was mentioned, and I imagine it will be available no later than when the OCS Wave 14 release – which will be ‘late in 2010′. I have also heard several reports that Blackberry Enterprise Server 5.0.2 will support OCS 2007 R2 integration.

For more information see the previous blog entry: BlackBerry® Client Support for OCS R2.

Share and Enjoy:
  • Twitter
  • Digg
  • StumbleUpon
  • del.icio.us
  • Facebook
  • LinkedIn
  • MySpace
  • Reddit
  • Technorati

15 comments to BlackBerry Client for OCS 2007 R2 Update

  • Hi,
    This comments got caught in a SPAM filter and I didn’t see it until now.

    I know several companies that have installed this successfully, so the install should work. This is simple, but you might want to re-download the package to make sure it is not a corrupt download if you are still having the problem. On several occasions I have downloaded an installation file that looked ok, but was corrupt and I’ve had to download it again. Also check that the desktop install is on a supported platform.

    Curtis

  • Reg User

    We got our BES from v5.02 to SP3 with MR6.

    Blackberry Torch 2 (9810) on Leaked OS v7.1.0.205. Downloaded the OCS 2007 R2 client for Blackberry from Blackberry’s official website (https://swdownloads.blackberry.com/Downloads/entry.do?code=24E01830D213D75DEB99C22B9CD91DDD). Tried to installed it via Blackberry Desktop and get an error message stating that the install file is incompatible or corrupted.

    Help! I need to get OCS 2007 R2 for Blackberry working!!!

  • Thanks Bill – that’s correct. The bigger issue is that you cannot natively install an OCS 2007 R1 CWA in an OCS 2007 R2 deployment; if you had R1 beforehand, you can just leave the R1 CWA intact when you upgrade to R2, and you will be fine.

    If you only ever had R2 deployed, and want to install the R1 CWA, I have read that you can run the R1 Forest Prep and a Domain Prep with the Setup Tool (not the command line) and install an R1 CWA into an R2 Pool (as detailed here http://blogs.technet.com/ucedsg/archive/2009/06/04/i-need-to-support-rim-s-como-client-in-ocs-2007-r2.aspx).

    I have never tried that, and it sounds risky. I would be interested to know if you, or anyone, has had success doing this in a production environment,

    Thanks,

  • Bill

    You can get the BB OC IM client to work with OCS 2007 R2 but you need to use and OCS 2007 R1 CWA to make that happen. The current version of the BES still uses the AJAX UC API and therefore cannot talk directly to the R2 platform. We have this successfully deployed today for all who wish to use the BB OC IM client.

    Bill

  • Wilfred

    I tried the version on the net (released August 23rd 2010.).. doesnt work.. gives “Data Services Unavailable” error.

    Am using the 5.0 OS

  • Thanks for the update. This new version is still described as “BlackBerry Client for use with Microsoft Office Communications Server 2007″ (not 2007 R2), and there is no mention of 2007 R2 in the release notes, so I doubt there is R2 support, but let please let us know otherwise.

  • JD

    I see on BB site there is a new version of the communicator released August 23rd 2010.
    BlackBerry Enterprise IM 2.5.0.40 for use with Microsoft ( Desktop )
    Please Note: BlackBerry Enterprise Instant Messaging v2.5 is supported on Blackberry Device Software v4.5 and higher, including 6.0.
    Filename: oc2007_Desktop_2.5.40c.zip
    Filesize: 4,135 KB
    Date Posted: 23-Aug-2010

    haven’t been able to make it work yet…..

  • Matt

    Anyone have an update? Was it actually released this summer or was this another delay tactic from RIM?

  • Mike

    I see SP2 is out for BES 5.0. The release notes do not indicate OCS 2007 R2 support. Anyone have an update?

  • Clearly RM see no urgency to enable business users in OCS R2. But i guess we are not urgently trying to keep BB and their BES stuff either. good think apple has a solid working client.

    With apple we dont have to wait for a next version to support the previous. phew!!!

  • Raegan

    I have 5.0.2 beta and it’s not in there. I asked the question on the beta forums and they said it’s not in sp2 but is coming this summer.

  • Gav

    But will it support Group Chat???

  • Doug

    Move to Active Sync and get rid of your BES Server!

  • In my opinion, RIM has been dragging their feet on creating OCS R2 client simply because they want UC to revolve around their mobile devices and Blackberry Mobile Voice System (MVS) solution.

    The have had over a year to update R2 client and have choosen not to.

    Waiting for OCS 14 is just another “stall” tactic.

    Kevin

    To see who won the VoiceCon 2010 keynote showdown visit http://www.ucguys.com.

  • I’m also hearing that BES 5.0.2 will support OCS 2007 R2

Leave a Reply

 

 

 

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>